开源改变世界!!

不会在 macOS 10.12.2 上运行 #1140

推推 grbl 1年前 (2023-01-27) 109次浏览
关闭
clarkdv 打开了这个问题 2018 年 10 月 13 日 · 3条评论
关闭

不会在 macOS 10.12.2 上运行#1140

clarkdv 打开了这个问题 2018 年 10 月 13 日 · 3条评论

注释

不会在 macOS 10.12.2 上运行 #1140

安装了 macOS 10.12.2 和 Java 8 更新 181。

当我启动稳定版 UGS 平台时,我在终端中收到以下错误。
我已经能够运行每晚构建的 UGS 平台,但我需要能够运行稳定版本。

警告:发生了非法反射访问操作
警告:org.netbeans.ProxyURLStreamHandlerFactory(文件:/Users/cnc/Desktop/ugsplatform/platform/lib/boot.jar)对字段 java.net.URL.handler的非法反射访问
警告:请考虑将此报告给 org.netbeans.ProxyURLStreamHandlerFactory 的
维护者

不会在 macOS 10.12.2 上运行 #1140
晶圆厂 评论了 2018 年 10 月 19 日  

我在使用此 Java 版本更新的 Ubuntu 18.04 上有相同的消息:
openjdk version “10.0.2” 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.2)
OpenJDK 64-比特服务器虚拟机(build 10.0.2+13-Ubuntu-1ubuntu0.18.04.2,混合模式)

UGS 版本:通用 Gcode 平台 2.0 [每晚]/2018 年 10 月 14 日

警告:发生了非法反射访问操作
警告:org.netbeans.ProxyURLStreamHandlerFactory(文件:/home/fabrice/Documents/CNC/Logiciels/UGS_Platform/ugsplatform/platform/lib/boot.jar)非法反射访问字段 java。 net.URL.handler
警告:请考虑将此报告给 org.netbeans.ProxyURLStreamHandlerFactory 的维护者
警告:使用 –illegal-access=warn 启用进一步非法反射访问操作的
警告未来版本

UGS 打开,我可以使用它,但在可视化器中看不到任何东西。

不会在 macOS 10.12.2 上运行 #1140
作者

我的打不开,收到错误信息后就退出了。

不会在 macOS 10.12.2 上运行 #1140
合作者

看起来它运行的是 Java 9 或更高版本。UGS 需要 Java 8,确保您激活了正确的版本。

请参阅此说明:
https ://stackoverflow.com/questions/21964709/how-to-set-or-change-the-default-java-jdk-version-on-os-x

我正在关闭这个问题,因为它已经很老了,如果问题仍然存在,请随时再次打开。