开源改变世界!!

UGS 平台无法在 Lubuntu 18.04 上加载 #1392

推推 grbl 1年前 (2023-01-28) 129次浏览
关闭
UWBernie 打开了这个问题 2020 年 4 月 16 日 · 2 条评论
关闭

UGS 平台无法在 Lubuntu 18.04 上加载#1392

UWBernie 打开了这个问题 2020 年 4 月 16 日 · 2 条评论

注释

UGS 平台无法在 Lubuntu 18.04 上加载 #1392

我正在尝试在运行 Lubuntu 18.04 的旧上网本上运行 UGS 平台启动画面加载了一会儿,我看到了窗口,然后它关闭了。这是使用最后一个稳定版本和 java(openjdk 版本“1.8.0_242”)。注意我还尝试使用链接的 oracle java 1.8.0_251。尽管有警告,程序直到粗体行才终止

bernie@Bernie-1000HE:/Downloads/ugsplatform/bin$ ./ugsplatform
警告:发生了非法的反射访问操作
警告:org.netbeans.ProxyURLStreamHandlerFactory 的非法反射访问(文件:/home/bernie/Downloads/ugsplatform/platform/ lib/boot.jar) 字段 java.net.URL.handler
警告:请考虑将此报告给 org.netbeans.ProxyURLStreamHandlerFactory 的维护者
警告:使用 –illegal-access=warn 以启用进一步非法反射访问操作的
警告警告: 所有非法访问操作将在未来的版本中被拒绝
ld.so 检测到的不一致:dl-lookup.c: 111: check_match: Assertion `version->filename == NULL || !_dl_name_match_p (version->filename, map)’ 失败!
bernie@Bernie-1000HE:/Downloads/ugsplatform/bin$ java -version
openjdk version “1.8.0_242”
OpenJDK Runtime Environment (build 1.8.0_242-8u242-b08-0ubuntu3~18.04-b08)
OpenJDK Server VM (build 25.242-b08 , 混合模式)

使用每晚构建的 Linux 版本会导致以下错误,我猜这是因为我使用的是 32 位操作系统和处理器,而它期望是 64 位?

bernie@Bernie-1000HE:/Downloads/ugsplatform-linux/bin$ ./ugsplatform
./../platform/lib/nbexec: 第 421 行:/home/bernie/Downloads/ugsplatform-linux/jdk/jdk-13.0.1 +9-jre/bin/java: cannot execute binary file: 执行格式错误

UGS 平台无法在 Lubuntu 18.04 上加载 #1392
所有者

这似乎是 Java 运行时的问题。我能够在 ubuntu 18.04 上重现这个问题openjdk version "11.0.6" 2020-01-14

带有捆绑 JRE 的 UGS 版本运行良好,请尝试此处的版本:https ://github.com/winder/Universal-G-Code-Sender#downloads

UGS 平台无法在 Lubuntu 18.04 上加载 #1392
合作者

关闭,因为我们没有得到用户的回应