开源改变世界!!

UGS Visualizer 与默认的 Raspberry Pi400 视频驱动程序不兼容 #1516

推推 grbl 2年前 (2023-01-28) 246次浏览
打开
gartlana 打开了这个问题 2021 年 1 月 17 日 · 0 条评论
打开

UGS Visualizer 与默认的 Raspberry Pi400 视频驱动程序不兼容#1516

gartlana 打开了这个问题 2021 年 1 月 17 日 · 0 条评论

注释

UGS Visualizer 与默认的 Raspberry Pi400 视频驱动程序不兼容 #1516
加特兰纳 评论了 2021 年 1 月 17 日  

描述错误 对错误
内容的清晰简洁的描述:

  1. 在 MicroSD 上创建并安装 Raspberry OS Buster(32 位)并启动 Pi400
  2. 从http://winder.github.io/ugs_website/download/下载并安装最新的或最新的 ugsplatform
  3. Linux ARM 或 Linux 版本产生相同的结果)。
  4. 执行 ugsplatform。
    结果:Visualizer 将仅显示空白区域。

临时解决方法/修复:
按如下方式更改视频驱动程序
:从终端内部通过命令访问高级配置功能:sudo raspi-config
b。选择“高级选项”
C. 选择“A2 GL Driver”
d:选择“G1 Legacy Original non-GL desktop driver”
e:通过首选方法将 /opt/vc 重命名为 /opt/vc.old(例如 sudo pcmanfm 以在超级用户模式下调用文件管理器)。
f: 须藤重启

结果 ugsplatform 现在将根据设计在可视化器中显示 gcode 文件形状、工具移动等。

*注意:在此解决方法配置中,其他需要较新驱动程序的应用程序将失败(例如,提供的桌面标准构建 Chromium 浏览器)。

版本
应用程序:
产品版本:通用 Gcode 平台 20210116
Java:1.8.0_275;OpenJDK Client VM 25.275-b01
Runtime: OpenJDK Runtime Environment 1.8.0_275-b01
System: Linux version 5.4.83-v7l+ running on arm; UTF-8;en_US (ugsplatform)
用户目录:/home/pi/.ugsplatform/2.0.7-SNAPSHOT/dev
缓存目录:/home/pi/.ugsplatform/2.0.7-SNAPSHOT/dev/var/cache

硬件
Pi400 套件,USB 连接到运行 GRBL 1.1 固件的 Adruino UNO

**操作系统:

Raspberry Pi O/S Buster(32 位):
pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME=”Raspbian GNU/Linux 10 (buster)”
NAME=”Raspbian GNU/Linux”
VERSION_ID=”10″
VERSION= “10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL=” http://www.raspbian.org/ “
SUPPORT_URL=” http://www.raspbian.org/RaspbianForums “
BUG_REPORT_URL=” http:/ /www.raspbian.org/RaspbianBugs “

其他背景
我现在有一个可以使用的工作平台,所以这份报告只是为了更广泛的社区和开发工作,标记 Pi400 平台标准/提供的构建中的视频驱动程序兼容性问题。

免费注册 在 GitHub 上加入此对话。已有帐户? 登录评论
标签
还没有
项目

还没有

发展

没有分支机构或拉取请求

1名参加者
UGS Visualizer 与默认的 Raspberry Pi400 视频驱动程序不兼容 #1516

喜欢 (0)