开源改变世界!!

自动更新的问题。 #246

推推 grbl 1年前 (2023-01-26) 96次浏览
关闭
abatinxs 打开了这个问题 2018 年 1 月 10 日 · 6条评论
关闭

自动更新的问题。#246

abatinxs 打开了这个问题 2018 年 1 月 10 日 · 6条评论

注释

自动更新的问题。 #246

当我运行 LaserGRBL(现在是 2.8.35)时,会出现带有信息的窗口 – 新版本可用 2.8.8。下载结束后,我看到信息 – 自动更新失败。请从 lasergrbl 站点手动下载新版本。这是我的电脑、服务器或新更新 lasergrbl 的问题?最后 – 我没有看到可供下载的 2.8.8 版本 :)

自动更新的问题。 #246
所有者

你在Windows XP上运行它吗?

自动更新的问题。 #246
作者

我在 Windows 7 64 位 (Dell E4310) 上运行

自动更新的问题。 #246
所有者

这个问题很奇怪。

v2.8.35 实际上是最新(最新)版本。LaserGRBL 检测最新版本检查 url 的内容:https ://api.github.com/repos/arkypita/LaserGRBL/releases/latest

自动更新的问题。 #246

“tag_name”的内容作为最新版本使用。实际上它显示 “tag_name”: “v2.8.35”

V2.8.8 很老了。我不知道为什么你的安装发现这个版本是最新的。
如果您在浏览器中打开https://api.github.com/repos/arkypita/LaserGRBL/releases/latest ,您会看到什么?

自动更新的问题。 #246
作者

当我打开此链接时,我看到:
“html_url”:“ https://github.com/arkypita/LaserGRBL/releases/tag/v2.8.35 ”,
“id”:8999345,
“tag_name”:“v2.8.35”,

第一个打印屏幕:
https ://i.imgur.com/7aW4ADU.jpg

第二个打印屏幕是我打开你的链接时看到的内容
https://i.imgur.com/kWy2BrF.jpg

Github 不支持在此窗口中查看照片。您必须复制链接并粘贴到您的浏览器中。

自动更新的问题。 #246
所有者

请注意,您使用的是旧的 v2.8.8 版本。LaserGRBL 只是警告您最新版本是 2.8.35。

修改了自动更新程序,不兼容老版本,自动更新失败。

只需下载并手动安装最新的 v2.8.35

自动更新的问题。 #246
所有者

ps github支持alt+stamp或win+stamp(截图)和ctrl+v粘贴评论,无需使用任何外部服务