开源改变世界!!

1.0.8 上的 RXTX 版本不匹配 #180

推推 grbl 1年前 (2023-01-26) 80次浏览
关闭
gerritv 打开了这个问题 2014 年 8 月 6 日 · 8条评论
关闭

1.0.8 上的 RXTX 版本不匹配#180

gerritv 打开了这个问题 2014 年 8 月 6 日 · 8条评论

注释

1.0.8 上的 RXTX 版本不匹配 #180

我使用 NetBeans 从源代码构建(NB 是最新的 AFAIK,我机器上的 Java 也是最新的)。
你能帮我解决这两个错误吗?RXTX 版本不匹配和缺少 MessagesBundle en.properties?当 UCS 发送到 Grbl 时,我有时会出错,我想首先消除这些错误,以防它们是原因。

C:\Users\gerrit\Downloads\UCS 1.0.7>java -jar -Xmx256m UniversalGcodeSender.jar
[启动] 信息:myJarPath=file:/C:/Users/gerrit/Downloads/UCS%201.0.7/UniversalGcodeSender.jar
[JarClassLoader] 信息:setProperties(com.simontuffs.onejar.JarClassLoader@121f34d0)
[JarClassLoader] 信息:oneJarPath=file:/C:/Users/gerrit/Downloads/UCS%201.0.7/UniversalGcodeSender.jar
[引导] 信息:使用 JarClassLoader:com.simontuffs.onejar.JarClassLoader
[JarClassLoader] 信息:oneJarPath=file:/C:/Users/gerrit/Downloads/UCS%201.0.7/UniversalGcodeSender.jar
[JarClassLoader] 信息:findResource():无法定位“资源/MessagesBundle_en.properties”

稳定库

本机库版本 = RXTX-2.2-20081207 Cloudhopper 构建 rxtx.cloudhopper.net
Java 库版本 = RXTX-2.1-7
警告:RXTX 版本不匹配
Jar 版本 = RXTX-2.1-7
本机库版本 = RXTX-2.2-20081207 Cloudhopper 构建 rxtx .cloudhopper.net
2014 年 8 月 5 日下午 12:02:01 com.willwinder.universalgcodesender.SettingsFactory loadSettings
信息:加载设置。
2014 年 8 月 5 日下午 12:02:01 com.willwinder.universalgcodesender.SettingsFactory loadSettings
信息:设置文件位置:C:\Users\gerrit\UniversalGcodeSender.json

1.0.8 上的 RXTX 版本不匹配 #180
所有者

你用什么蚂蚁脚本来构建你的罐子?

1.0.8 上的 RXTX 版本不匹配 #180
作者

Build.xml,并根据 git Master 导入 o​​ne-jar-ant-task.xml。这是我第一次尝试做一些 java 开发,谢天谢地,在过去的 49 年里我能够避免它。我正在安装 NetBeans 8.0,完整包以查看是否是问题所在。

1.0.8 上的 RXTX 版本不匹配 #180
作者

同样的问题,它似乎与作为 UCS Git 一部分的 RXTX jar 有关?

1.0.8 上的 RXTX 版本不匹配 #180
所有者

确保您使用的是“onejar-build-release”目标。RXTX 警告在 Windows 上是正常的,应该不是问题,已经有一段时间了。

1.0.8 上的 RXTX 版本不匹配 #180
作者

那是我正在使用的目标,它正确地构建了发布目录。我还注意到,双击 jar 文件会导致与 Grbl 的通信更加可靠,似乎 start.bat 打开的命令窗口会以某种方式干扰。还不确定,如果我看到一些东西,我会打开一个新问题。

谢谢你的帮助,这是 Grbl imo 最好的 GUI