开源改变世界!!

不在 OS X El Capitan 中启动,最新版本使用最新的 Java 1.8 build 101 #464

推推 grbl 1年前 (2023-01-26) 64次浏览
关闭
papastanley 打开了这个问题 2016 年 8 月 22 日 · 1条评论
关闭

不在 OS X El Capitan 中启动,最新版本使用最新的 Java 1.8 build 101#464

papastanley 打开了这个问题 2016 年 8 月 22 日 · 1条评论

注释

不在 OS X El Capitan 中启动,最新版本使用最新的 Java 1.8 build 101 #464

嗨,大家好,

我有两台机器…

我的旧设置是 Yosemite 10.10.5,带有 Java 1.8.0_45 和 UGS v 2,从 2015-06-03 开始​​每晚构建。这很好用——我使用的是 Darkly Labs Emblaser(基本上是 Arduino GRBL 2d 激光)

我的新设置正在尝试使用 Java 1.8.0_101 和 2016 年 8 月 22 日的最新版本在 El Capitan 上运行。

“新”设置正在停滞 – 似乎是在首次启动时在终端中报告的加载设置/应用设置阶段之后。只是坐在那里转动它的轮子。虽然我不能确定它,但感觉沙箱可能会阻止 GUI 以某种方式出现,或者在绘制到屏幕时出现了一些窗口错误。控制台中没有什么明显的,但我不是堆栈跟踪器……

在你的网页上,当你说“在 Mac OS X 上测试”时,最好有一些系统细节,或者至少有一些建议的日期——我不知道你是否经常在 OS X 上使用 Java 1.7 和 1.8 进行测试和最近的 3 个 OS X 版本,或者你是否很久以前做过一次,但因为你没有运行它而没有做过。

请指教?papastanley@me.com和/或github 上的papastanley

下一步是重建干净的系统,但是仅仅让一个小程序运行 IMO 就太过分了 ;-)

干杯,喜欢你的工作

.:S:.

不在 OS X El Capitan 中启动,最新版本使用最新的 Java 1.8 build 101 #464
所有者

@papastanley我已经使用 1.8.0_80 一段时间了,所以我使用 OSX El Capitan 10.11.5 以及 1.8.0_101 和 1.8.0_102 对其进行了测试。两者都启动良好。我猜可能有某种安全设置阻止 UGS 访问可能导致挂起的设置目录。

1.0.9 适合你吗?
如果是,从命令行确实ls ~/Library/Preferences/ugs给你一个错误?

至于测试——你是对的,我对此不是很正式(对于夜间构建,主要只有单元测试)。幸运的是,UGS 有很多用户,我会认真对待问题报告(比如这个),所以我认为我们的覆盖范围很广。