开源改变世界!!

无法在旧版本上导入图像 #512

推推 grbl 1年前 (2023-01-27) 82次浏览
关闭
jranavaya 打开了这个问题 2018 年 11 月 28 日 · 7条评论
关闭

无法在旧版本上导入图像#512

jranavaya 打开了这个问题 2018 年 11 月 28 日 · 7条评论

注释

无法在旧版本上导入图像 #512

你好,

所以我已经使用 LaserGRBL 一段时间了,并且一直在使用旧的 2.8.52 版本。我最近升级到最新的 3.0.3 版本并且在我的雕刻中遇到了一些问题。我不确定是软件问题还是硬件问题,所以我决定卸载并再次尝试 2.8.52 版本。这一次似乎没问题,直到我进入导入图像光栅屏幕。我可以将其全部设置好,但是当我点击继续设置雕刻速度和尺寸时,出现此错误。

除了 3.0.3 版本之外,无论我使用哪个版本都会发生这种情况。知道它是什么吗?

无法在旧版本上导入图像 #512

无法在旧版本上导入图像 #512

事实上,我刚刚再次检查过,似乎每个版本都可以从最新的到 2.9.2。任何早于它的东西都不起作用并给出该错误。

无法在旧版本上导入图像 #512
所有者

尝试删除此文件:C:\Users\YOUR USER NAME\AppData\Roaming\LaserGRBL\LaserGRBL.Settings.bin
这会重置 lasergrbl 配置和旧选项

无法在旧版本上导入图像 #512
所有者

或者更好:你能压缩并发送给我,这样我就可以重现错误并使我的代码更强大吗?
我的邮箱:info@lasergrbl.com

无法在旧版本上导入图像 #512

尝试删除此文件:C:\Users\YOUR USER NAME\AppData\Roaming\LaserGRBL\LaserGRBL.Settings.bin
这会重置 lasergrbl 配置和旧选项

谢谢,我试过了,但没有任何改变。当我尝试 2.8.50 版时出现同样的错误。

或者更好:你能压缩并发送给我,这样我就可以重现错误并使我的代码更强大吗?
我的邮箱:info@lasergrbl.com

我把文件发给你了:)

无法在旧版本上导入图像 #512
所有者

所以我已经使用 LaserGRBL 一段时间了,并且一直在使用旧的 2.8.52 版本。我最近升级到最新的 3.0.3 版本并且在我的雕刻中遇到了一些问题。我不确定是软件问题还是硬件问题,所以我决定卸载并再次尝试 2.8.52 版本。这一次似乎没问题,直到我进入导入图像光栅屏幕。我可以将其全部设置好,但是当我点击继续设置雕刻速度和尺寸时,出现此错误。

当您更新到 v3.0.3 时,宽度、高度、偏移 X 和 Y 的值已更新为浮点数(带小数点)而不是整数。然后,您使用的值作为浮点数存储在配置文件中(作为上次使用的值)。

当你运行旧版本时,旧版本对这个变化一无所知,旧代码试图将它们读取为整数,所以会出现异常。当你降级时你应该删除设置文件(不总是,但在这种情况下你应该)。